3.0 beta 2

Can't reload XML data from iframe in Mozilla (with code already patched)

Hi, I'm having a problem: I have a grid in the main page, and an iframe where I do "remote scripting" with PHP.

In the main page I have, along with all the grid stuff, this function which loads XML data generated by another PHP script which creates XML dinamically. Notice that I pass the dinamically generated URL as a parameter to this function:

function myGrid_xmlGetData(url)
   var myGrid_table = new Active.XML.Table;
   myGrid_table.setProperty('URL', url);

   myGrid.setModel('data', myGrid_table);


function refreshDir()
   myGrid_xmlGetData('{$xmlURL}' + selected_value + '&ran=' + new Date().getTime());

Then, in the iframe I have this, generated by PHP:

<body onLoad="parent.refreshDir();">

I have alert'ed the url in the myGrid_xmlGetData function and it shows fine, but in the Javascript Console I get the error "xml.setProperty is not a function. Source file source/lib/xml/table.js". The line in the table.js source code reads as follow:

xml.setProperty("SelectionLanguage", "XPath");

Any idea? :(

P.S. I'm testing in Mozilla Firefox 1.0.3 on Slackware/KDE and Windows XP. I already patched the gecko.js file with the workaround for this Firefox version found in this forum. The data loads fine from the main page, using the same refreshDir function. The same codes work fine in MSIE 6+

April 26,

This topic is archived.

See also:

Back to support forum


Version 2

Looking for AW 2.6 ?
The old site is here.