3.0 beta 2

My application gives error 'Active' object undefined

Im using Tomcat 4.0, to run the Activer widget application, the version is activewidgets-grid-1.0-gpl. I have copied the examples folder which comes with distribution in the webapps folder of Tomcat. I then copied the runtime folder in my web server. The problem is that whenever I try to run any example page eg ..\example\basic.html .it always gives me
java script error that 'Active' object undefined. It seems it is unable to identify Active object, can any body help me why is this so.....although I have copied the runtime folder in the correct path

thnx a lot
New User
June 27,
Make sure your arrays are formed properly...

data & columns
June 27,
Hi
Thnx for ur answer........but I want to make a correction from my side. I had copied examples folder from ..\activewidgets-grid-1.0-gpl\ActiveWidgets\examples in my Tomcat\webapps folder (like any other we application). But it gave me error : Active Object undefined.
I want to mention that i had not made any changes in the examples.
Then I dont understand ur point :
Make sure your arrays are formed properly...
data & columns

thnx a lot


New User
June 29,
You should copy both /examples and /runtime or complete ActiveWidgets folder
Alex (ActiveWidgets)
June 30,
: 'Active' is undefined
be sure that the path in
<script src="../../runtime/lib/grid.js"></script>
is correct. Remember that this is a relative path, so you have to check runtime folder is two directories back from your example folder. You can also copy the runtime folder into example's folder and replace the instruction with
<script src="runtime/lib/grid.js"></script>
This happens because "Active object" is define in grid.js
good luck
July 10,

This topic is archived.

See also:


Back to support forum

Search

Version 2

Looking for AW 2.6 ?
The old site is here.