3.0 beta 2

Problem with scrolling when grid's width and height is set in percentage

Hi,

I have a grid with width=100% and height=100%
it is inside the table cell that is 20% of the table width and 100% of its height.
When I have a large data set and try to scroll down:
1. The scroller would jump back up
or
2. The grid would scroll down but rows would be empty

Thanks,
Andrew.
Andrew
December 9,
Andrew,

try adding style="table-layout:fixed" to the parent table.
Alex (ActiveWidgets)
December 9,
tried to apply it to the outer table
after that grid is drawn as a single line.

I can e-mail you a zip file with that example if this will help
please let me know
Andrew
December 10,
yes, please e-mail me an example.
Alex (ActiveWidgets)
December 10,
please send me ur e-mail ID to abarvinsky at gmail
Andrew
December 10,
I experience a similar problem:

the grid (height: 100%; width: 100%) is inside a span with style="DISPLAY: inline-block; POSITION: absolute; TOP: 0px; LEFT: 0px; WIDTH: 494px; HEIGHT: 81px".

the grid's scrollbar moves correctly, but the grid itself does not scroll down.
tobias
December 10,
Yeah i'm have the same problem!

The scroll bar not scroll...
Lucas Moretto
January 25,
I am experiencing similar scrolling issues (I have RC1). If I have the grid nested in single table cell like the following, the scrolling goes haywire. The grid data doesn't scroll, but the row selectors do. If I size the window to be smaller (600x600), it works OK, but if I resize to larger (1600x1200), the problems persist.

<table style="table-layout:fixed;height:100%;width:100%">
<tr>
<td>
<table style="table-layout:fixed;height:100%;width:100%">
<tr><td>Title</td></tr>
</table>
</td>
</tr>
<tr>
<td>
[ Grid goes here, 100% height and 100% width]
</td>
</tr>
</table>

(By the way, how do you post so example code shows nicely formatted?)
Mike
February 3,
I'm having exactly the same issue.

I'm displaying the grid on a page within an IFrame. The page displayed in the IFrame contains a table with the style set to table-layout:fixed (as suggested above). The grid displays perfectly, but as soon as you scroll, the whole thing goes pear-shaped.

I'm not sure how the scrolling mechanism works, but it's as if the grid refreshes half-way through the scroll, and then disregards any offset value that may (or may not) have been set. The grid jumps back to the top, and the scroll bar becomes ineffective.

Clicking on any of the headers brings the scrolling back to life, but once you start scrolling, the grid refreshes again, and you're back to square one.

If you scroll down with the keyboard arrow keys, the grid stays static, but the highlight does move to the bottom of the grid (which of course you can't see)

Any suggestions?
Stuart
February 4,
Solved.

Sometimes it's hard to determine wether the scrollbar is part of activegrid or comes from the outer container. Setting the container to "overflow: hidden;" solved the problem.
Tobias
February 6,

This topic is archived.

See also:


Back to support forum

Search

Version 2

Looking for AW 2.6 ?
The old site is here.