:: Forum >> Version 2 >>

AW Grid 2.0.1 is blank on IE7

We have the grid object functioning on Firefox & IE6, we are getting reports that our grids are empty on IE7 - I upgraded to 2.0.1, and our grids are still empty on IE7. I've searched some posts, added some CSS, but the grids are still blank. Please advise.

TIA,
Dave
Dave Hulting
Thursday, January 18, 2007
Make sure you also replaced the aw.css on the server with the new version and also clear browser cache. If this still does not help - please send me an example.
Alex (ActiveWidgets)
Friday, January 19, 2007
We had a similar problem, found out certain versions of IE don't support attachEvent(), so the grid doesn't render, no solution found yet..
JeffT
Friday, January 19, 2007
Are you sure? I think any recent version of IE must support attachEvent(). How did you come to the conclusion that it does not?
Alex (ActiveWidgets)
Friday, January 19, 2007
I tested it with this in aw.js:
if (AW.attachEvent){alert('true');}
On the browsers in question the alert box doesn't show, and the attachEvents (onmousedown, etc) after that don't happen or produce a javascript "object doesn't support..." error. They also do not support addEventListener, which I tried to use instead.
It is truly odd, I've seen it happen on a Windows 2000/IE6 and an XP/IE7 install. I think these are some sort of customized browsers, but I'm not sure, they have no other problems that the users can see.
Is there any other way to attach events?
JeffT
Friday, January 19, 2007
I've recently had a similar sort of problem with IE7. I can load the grid with data but after clicking on a row/cell, the entire contents of the grid disappears. Was this the same for you, Dave? Or did the grid load with no data to start with?

In IE6 and Firefox, there was no problem. Only IE7.

I did find a solution.

After I wrote the grid to screen, I refreshed it.. and no problems since. --> document.write(obj); followed by obj.refresh();

Hope this is of some help.
Geoff
Sunday, January 21, 2007
I cannot get this to work in IE7 (7.0.5730.11). The obj.refresh() doesn't get the grid to populate. But FF and IE6 are fine with or without the refresh().

Code:

<script>

var myCells = [
["MSFT","Microsoft Corporation", "314,571.156", "32,187.000"],
["ORCL", "Oracle Corporation", "62,615.266", "9,519.000"],
["SAP", "SAP AG (ADR)", "40,986.328", "8,296.420"],
["CA", "Computer Associates Inter", "15,606.335", "3,164.000"],
["ERTS", "Electronic Arts Inc.", "14,490.895", "2,503.727"]
];

var obj = new AW.UI.Grid;
var obj = new AW.Grid.Extended;

obj.setCellText(myCells);
obj.setColumnCount(4);
obj.setRowCount(5);

document.write(obj);
obj.refresh();
</script>

Would having four grids on the page cause problems? TIA
Dave Hulting
Friday, March 23, 2007
This version of IE (7.0.5730.11) alerts ''true" with the attachEvent script from JeffT
Dave Hulting
Friday, March 23, 2007
Dave,

this might happen if you are using 2.0.1 and the grid is inside the element with display:none style. In this case upgrading to 2.0.2 should solve the problem.
Alex (ActiveWidgets)
Tuesday, March 27, 2007



This topic is archived.

Back to support forum

Forum search