:: Forum >> Version 2 >>

Performance in IE.

I have a large scale Ajax web application which uses many ActiveWidget components spread over several tabs on a single web page.

Most of these are loaded in at the the start, and it takes several seconds to load in the application (and render the components, most of which are in display: none divs) in FireFox. In IE however it takes as much as 6 times as long!

Whilst I understand that IE isn't the best for running javascript, the application doesn't really have all that much to slow it down (No multiple global lookups for example).

Assuming that the ActiveWidgets loading/rendering is slowing it down, is there a solution to this problem without me having to half rewrite the application?

James at i4
Tuesday, February 20, 2007
Further from my previous post, I have confirmed that the document.write() of an activewidgets component is the cause of the slowdown in IE. Is there a way to speed that up?
James at i4
Wednesday, February 21, 2007
Do you have grids on this page or its just many small objects (tabs, buttons etc.)?

If you have grids - they most likely make most of the load and it would be much better to insert them 'on demand', when the div becomes visible for the first time.
Alex (ActiveWidgets)
Wednesday, February 21, 2007
Thanks Alex, I have done that with a bit of funky div-instead-of-document.write() and some innerHTML newfangledness. It has halved the load time, though is still twice as slow as firefox.

Though i'm not assuming the rest of the loading and general slowness is AW related, have you anymore AW performance tips for IE?
Wednesday, February 21, 2007
That's funny, we have the complete opposite problem, takes so long to load in ff we had to stop supporting it, loads in ie like a flash, plus ff still doesn't support a lot of things.
Shea R
Wednesday, February 21, 2007



This topic is archived.

Back to support forum

Forum search