:: Forum >> Version 2 >>

Column width CSS not working -- please help!

More information on this topic is available in the documentation section: /active.howto.style.columns/column-width.html.

Hi, I followed the advice in another thread about how to set column widths, but unfortunately it doesn't seem to work. Here is my code, what am I doing wrong? It doesn't seem to matter where I put the <style> tag either. Thanks in advance!

<html>
<head>
<!-- include AW stylesheet and script -->
<link href="ActiveWidgets/runtime/styles/xp/aw.css" rel="stylesheet" type="text/css" ></link>
<style>
.active-column-1 {width:400px}
</style>
<script src="ActiveWidgets/runtime/lib/aw.js"></script>
</head>
<body>
<script>

var myHeaders = <?php echo aw_headers($dataset); ?>
var myCells = <?php echo aw_cells($dataset); ?>
var obj = new AW.Grid.Extended;
obj.setSize(800,800);
obj.setHeaderText(myHeaders);
obj.setCellText(myCells);
obj.setColumnCount(myHeaders.length);
obj.setRowCount(myCells.length);
document.write(obj);

</script>
Hello world!
</body>
</html>
Jim
Sunday, August 19, 2007
I believe the styles should be
.aw-column-0 {width:400px}
.aw-column-1 {width:400px}
if you are using latest version of AW. I think the style entry .active-column-1 was the 1.0 version of AW.
Bryn
Sunday, August 19, 2007
Outstanding, thank you!! I suppose when things like this change from version to version, it's unavoidable that the comments in the forum will be misleading :) Thanks again!
Jim
Sunday, August 19, 2007



This topic is archived.

Back to /active.howto.style.columns/column-width.html

Documentation:

Forum search