:: Forum >> Version 2 >>

Google Chrome bug with radio widget

More information on this topic is available in the documentation section: /general.bugs/2-5-3.html.

I was testing a page I'd written specifically for FireFox with Google Chrome. It mostly works. Chrome must be Gecko-compatible. All the moz CSS settings work too. The Chrome version is 1.0.154.53.

Anyway, the only thing that didn't work correctly was the height for radio buttons. Debugging on FireFox with Firebug revealed that the height was set to auto. So I added this style -
.aw-ui-radio    {height:40px}
 
to fix it (I had two radio options).

The radio widget sits inside a div with a fixed height but that was inside another div with a percentage height. Without the fix, the radio widget was taking up most of the vertical space.
Anthony
Wednesday, April 22, 2009
Found a simpler fix for this.

I also noticed that the radio button items in GC had a odd outline around their text, so I made this style change:
.aw-item-text    {outline:none}
 
which nuked the outline problem (also got rid of them in FF) as well as fixing the auto height issue without the need for the previous style.
Anthony
Friday, April 24, 2009
Great! ...Thanks for investigate it ( and for the fix) :-)
Carlos
Friday, April 24, 2009
I'm not sure if its a bug in Chrome or not. I was testing out the canvas element in the HTML 5 specification. Seems this works in most browsers except IE, of course.

Anyway, I've put it up on my web pages at http://www.users.on.net/~asm/canvas/

Everyone can feel free to test it with other browsers (except IE ;-) or copy it and take out the above fix to see the result in Chrome. Other browsers may uncover other issues. FF works correctly.

I've also uncovered some limitations to the canvas specification - but this isn't the forum to discuss those.
Anthony
Friday, April 24, 2009



This topic is archived.

Back to /general.bugs/2-5-3.html

Documentation:

Forum search