:: Forum >> Version 1 >>

ActiveWidgets STILL busted in latest Mozilla nightly

More information on this topic is available in the documentation section: /general.faq/supported-browsers.html.

All fields in grids appear with horizontal scrollbars completely obscuring their contents.

Steps to reproduce:

1) download 1.8a4 or latest nightly from Mozilla.org and install on Windows ME or Windows XP (not yet tested on Linux)

2) point browser to www.activewidgets.com

3) Bam! Sample widget on front page is busted.

Sample grid works in Mozilla 1.7.3, and in Firefox 1.0 (based on 1.7 branch of gecko)

Severity: critical. Renders grid unuseable. If not fixed, ActiveWidgets will not be useable on future Mozilla 1.8+ branch releases.
j. vance
Wednesday, November 10, 2004
This is another strong reason to use Internet Explorer instead of this buggy Mozilla browser (joke).
Alex (ActiveWidgets)
Wednesday, November 10, 2004
you must be begging to be flamed!!!
(works GREAT in firefox 1.0)
Travis Harris
Wednesday, November 10, 2004
Actually the grid was working fine since Mozilla 1.2/Phoenix 0.5 with a few minor exceptions (like Firefox 0.8 tutorial crash). I've just downloaded 1.8a4 and confirm that the issue exists. I don't have a workaround yet.
Alex (ActiveWidgets)
Wednesday, November 10, 2004
Maybe post a bug at bugzilla.mozilla.org? It'd be more useful coming from you. One thing I noticed - lots more complaining in the JavaScript console:

unknown property "box-sizing"
unknown property "filter"
unknown property "xcolor"
unknown property "xvertical-align"
error parsing value for property "cursor"
unknown property "text-overflow"

hmm... you're not checking for document.all, are you? Because the 1.8a branch has added silent support for document.all, IIRC - so you might be branching to the wrong css stuff.
j. vance
Saturday, November 20, 2004
This appears to be a mozilla bug. Mozilla introduced support for overflow-x and overflow-y in 1.8a, however setting overflow-y to 'hidden' forces overflow-x to 'auto' and then you see unexpected scrollbars.

Here is the fix:

.active-grid-row.gecko, .active-box-normal.gecko {
    
overflow-yvisible;
}

 
Alex (ActiveWidgets)
Sunday, November 28, 2004
Thanks! I'll patch that in after the holidays and see how it works.
j. vance
Saturday, December 25, 2004
How do I include this
.active-grid-row.gecko, .active-box-normal.gecko {
overflow-y: visible;
}

in my code make it work? Can you let me know
Lakshmisri
Monday, March 27, 2006
All this is now included in the AW 1.0.2 download and I presume part of V2, not started using V2 yet ;)
J
Tuesday, March 28, 2006
This problem was fixed in 1.0.2 and 2.0 was ok from the start.
Alex (ActiveWidgets)
Wednesday, March 29, 2006



This topic is archived.

Back to /general.faq/supported-browsers.html

Documentation:

Forum search