:: Forum >> Version 1 >>

A longshot but... embed an svg into grid cell

Hey,

I know this may a longshot from making this happen but I thought I'd give it a shot. I display rows of images either from a url or from a stream no problem in the grid just putting a <img> in the data. What I was now trying to do was to display a small svg image on each row by using the same technique except with <object> or <embed> tags. Neither works though. The grid doesn't want to size itself when painted, although it looks like the images might be appearing. Any clue what's going on here? Should I abandon the idea? or do you think it's doable? Any help is appreciated.
Paul
Monday, January 26, 2004
I don't see anything wrong with <object> or <embed> tags inside a grid cell except maybe performance/memory consumption. Maybe you just need to play with CSS (margins? display:inline?) to make them visible.

Don't expect grid to resize itself. Grid is NOT based on the <TABLE> tag. Each cell is just a <DIV> element with overflow:hidden. You need to explicitly set the width and the height of the columns/rows.
Alex (ActiveWidgets)
Monday, January 26, 2004
Ok sounds good.. The problem I had is not setting the row heights or cell widths. Thats understood. I currently am running the grid at a explicitly set height and width. One grid, displaying actually gif's 64x64 no problem, width the row, and cell height adjusted accordingly. I then duplicated that grid on another , except am using the <embed> to refernece a set of svg's the same exact size, and the funny result i see is the grid doesn't actually size itself at all when loaded. The cell and row widths are set but the grid itself is half the size it should be. Wierd..

Well anyways, its probably something in my code somewhere if you don't think there should be a problem. Thanks for the info. I'll let you know what I find out.
Paul
Tuesday, January 27, 2004



This topic is archived.

Back to support forum

Forum search