:: Forum >> Version 1 >>

jsp Firefox 1.5 activewidgets-grid-1.0.2-gpl

Hi!

I use Tomcat 5.5.9 and firefox 1.5. If I write a jsp page and run it then
the grid does not work on the jsp page. If I save the source of jsp page
and I rename it to another name (example: none.html), then the html page works fine.

What should be the reason that the jsp page doesn't work well?

Szacsa
Saturday, December 17, 2005
Hmm that is strange, I am using the grid with jsp very much and I didn't encounter that. I deploy my application in a standalone Tomcat 5.5.9 in Windows XP and Firefox 1.0.7 for testing. If you already have some jsp code in your page, there might be some error in the code that affects the grid to be displayed, like obj.setRowCount(<%=rowcount%>) and rowcount is blank. Check it in your browser again then view the source if the grid script is missing something.
romz
Saturday, December 17, 2005
Hi Romz!

I use firefox 1.5.

This is my jsp code :

<%@page contentType="text/html"%>
<%@page pageEncoding="iso-8859-2"%>


<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-2">
<title>browser</title>

<link href="runtime/styles/xp/grid.css" rel="stylesheet" type="text/css" ></link>
<script src="runtime/lib/grid.js"></script>

<!-- grid format -->
<style>
* {-moz-box-sizing: border-box;}
html { width: 100%; height: 100%; margin: 0px; padding: 0px; overflow: hidden}
body { width: 100%; height: 100%; margin: 0px; padding: 50px; overflow: hidden; font: menu}
.active-controls-grid {border: 1px solid #ccc}

</style>
<script>
window.focus();
</script>

</head>
<body>

<script>
var obj = new Active.Controls.Grid;

obj.setColumnProperty("count", 5);
obj.setRowProperty("count", 10);
obj.setDataProperty("text", "-");
document.write(obj);
</script>
</body>
</html>


If I run this code then the output will be an empty grid:
http://reikah-systems.uw.hu/jsp_page_output.JPG

if I rename the jsp page to html page, then it will be work fine:

http://reikah-systems.uw.hu/html_page_output.JPG

What should be the reason that the jsp page doesn't work well?
Szacsa
Sunday, December 18, 2005
The code you provided above worked fof me as temp.jsp

http://disasteromz.multiply.com/photos/photo/1/1.jpg

I'm using FireFox 1.0.7

Maybe you should upgrade your browser. If this still persist, maybe you should remove this portion in your code.

<!-- grid format -->
<
style>
* {-
moz-box-sizingborder-box;}
html width100%; height100%; margin0pxpadding0pxoverflowhidden}
body width100%; height100%; margin0pxpadding50pxoverflowhiddenfontmenu}
.
active-controls-grid {border1px solid #ccc}

</
style>
<
script>
window.focus();
</
script>
 
Run it again then make some debugging and trial and error. You should also consult with the examples from the reference here or from the samples you downloaded with the activewidgets distribution.
romz
Sunday, December 18, 2005



This topic is archived.

Back to support forum

Forum search